Configurar RIP

Veremos cómo configurar RIP, continuamos trabajando con la versión 2 de RIP, RIPv2 requiere tres comandos para una configuración básica y algunos comandos show para verificar el estado de RIPv2.

Configurando RIPv2

  1. Usa el comando router rip para habilitar RIP
  2. Usa el comando version 2 para usar RIP versión 2 exclusivamente.
  3. Agrega una o más redes con el comando network numero-red para habilitar RIP en las interfaces.

Una vez que RIP se habilita en las interfaces, realiza tres acciones separadas:

  • El enrutador envía actualizaciones de enrutamiento a través de la interfaz.
  • El enrutador escucha y procesa las actualizaciones que le llega en esa misma interfaz.
  • El enrutador notifica la subred conectada a la interfaz.

Ejemplo: Cómo Configurar RIP Versión 2 (RIPv2)

Ejemplo: Cómo configurar RIP versión 2
Ejemplo: Cómo configurar RIP versión 2
! Router A configuration
 router rip
  version 2
  network 172.16.0.0
  network 10.0.0.0
 ! Router B configuration
 router rip
  version 2
  network 10.0.0.0
 ! Router C configuration
 router rip
  version 2
  network 192.168.1.0
  network 10.0.0.0

Verificando la configuración de RIP

Existen tres comandos show principales para verificar que tan bien funciona RIP. La siguiente tabla lista estos comandos y su principal función:

ComandoPropósito
show ip route [rip]Rutas: Éste comando lista las rutas IPv4 aprendidas por RIP. El comando show ip route lista todas las rutas IPv4 y el comando show ip route rip lista sólo las rutas aprendidas por el protocolo RIP.
show ip protocolsConfiguración: Éste comando lista información sobre la configuración de RIP y además las IPs que aprendió de sus vecinos.
show ip rip databaseMejores rutas: Éste comando lista el prefijo de todas las mejores rutas aprendidas por RIP en este enrutador, incluidas rutas aprendidas por vecinos y rutas conectadas en la interfaz en donde RIP fue habilitado.

show ip route

RouterA#show ip route
Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route

Gateway of last resort is not set

     172.16.0.0/24 is subnetted, 1 subnets
C       172.16.1.0 is directly connected, FastEthernet0/0
     10.0.0.0/24 is subnetted, 2 subnets
R       10.2.2.0 [120/1] via 10.1.1.2, 00:00:16, Serial0/0
C       10.1.1.0 is directly connected, Serial0/0
R    192.168.1.0/24 [120/2] via 10.1.1.2, 00:00:16, Serial0/0 

Cada línea en la salida del comando show ip route revela muchos detalles acerca de una ruta. Usando la ruta 192.168.1.0/24 del enrutador R1 como ejemplo, los detalles serian los siguientes:

  • El número de red listado es 192.168.1.0 y su máscara es /24. (En algunos casos la máscara se encuentra en una línea superior antes de la ruta).
  • El siguiente salto del enrutador es la dirección IP 10.1.1.2.
  • La interfaz de salida es Serial 0/0.
  • El temporizador de RIP que mide cuanto tiempo ha pasado desde la ultima vez que R1 escucho sobre esta ruta en una actualización periódica de RIP fue hace 16 segundos.
  • La métrica para esta ruta (2 en este caso), esta listada en el segundo número entre los paréntesis rectangulares. Por ejemplo, entre R1 y la subred 192.168.1.0/24, dos enrutadores existen (R2 y R3), por tanto son dos saltos.
  • La distancia administrativa de la ruta es 120, el primer número entre los paréntesis rectos.

show ip route rip

R1# show ip route rip
! The same lines of legend show up here – removed for brevity
R       10.2.2.0 [120/1] via 10.1.1.2, 00:00:16, Serial0/0
R    192.168.1.0/24 [120/2] via 10.1.1.2, 00:00:16, Serial0/0

El comando show ip route rip lista sólo las rutas de RIP, no lista las directamente conectadas y las rutas locales.

show ip protocols

RouterA#show ip protocols
Routing Protocol is "rip"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Sending updates every 30 seconds, next due in 15 seconds
  Invalid after 180 seconds, hold down 180, flushed after 240
  Redistributing: rip
  Default version control: send version 2, receive version 2
    Interface             Send  Recv  Triggered RIP  Key-chain
    FastEthernet0/0       2     2
    Serial0/0             2     2
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
    10.0.0.0
    172.16.0.0
  Routing Information Sources:
    Gateway         Distance      Last Update
    10.1.1.2             120      00:00:24
  Distance: (default is 120) 
  • El subcomando versión 2 de RIP configura a R1 para enviar actualizaciones sólo de versión 2 y para procesar actualizaciones de versión 2 entrantes solamente.
  • La sumarización automática (por defecto es el comando auto-summary) esta habilitado.
  • El comando maximum-paths esta configurado en 4 (también es por defecto).
  • La sección “Routing for Networks” vuelve a listar la configuración de los comandos network, listando el número de redes en esos comandos. En este caso, son dos subcomandos RIP: network 10.0.0.0 y network 172.16.0.0.

También podemos ver el Gateway o la puerta de enlace que es la IP del siguiente salto por dónde llega a esas redes. En este caso sólo hay una puerta de enlace, pero podrían ser más dependiendo de la configuración y topología de red usada.

Deja un comentario