Cómo Configurar OSPF

Veremos cómo configurar OSPF en Cisco. Primero la configuración usando una sola área y luego varias áreas (OSPF Multiárea).

Configurar OSPF en una sola Área

Veremos cómo se configura OSPFv2 en una única área, esto puede ser tan simple como habilitar OSPF en cada interfaz del router y colocar esa interfaz en el área de OSPF correcta.

La siguiente lista describe los pasos de configuración para OSPF con una sola área:

Paso 1. Usa en el router el comando ospf process-id global en el router para ingresar al modo de configuración de OSPF en un proceso OSPF en particular.

Paso 2. (Opcional) Configura el ID del router OSPF haciendo lo siguiente:

  • A. Usa el comando router-id id-value para definir el ID del router, o
  • B. Usa el comando global interfaz loopback number, junto al comando ip address address mask, para configurar una dirección IP de loopback en la interfaz (elije la dirección IP más alta de todas las direcciones de loopback que funcionan), o
  • C. Confía en la dirección IP de la interfaz (elige la dirección IP más alta de todas las loopbacks que funcionan).

Paso 3. Usa una o más comandos network ip-address wildcard-mask area area-id router
para habilitar OSPFv2 en todas las interfaces que machean por la dirección y la máscara configuradas, habilitando OSPF en la interfaz para el área enumerada.

Nota: En OSPF para la máscara se usa la Máscara de Wildcard. Básicamente la wildcard es lo «inverso» a una máscara «convencional». Por ejemplo, para la máscara 255.255.255.0 la máscara de wildcard es 0.255.255.255. Nótese que esto se usa en el comando network.

Ejemplo dentro del modo OSPF en el router:

router ospf 1
  router-id 1.1.1.1
  
  network 10.0.0.0 0.255.255.255 area 0

interface S0/0/0
  ip address 10.1.1.1 255.255.255.0

router ospf 1 define el ID del proceso OSPF

router-id 1.1.1.1 configura el ID del router (opcional)

network 1.0.0.0.0 0.255.255.255 area 0 se puede ver en dos partes, primero agrega la red 1.0.0.0/8 en el proceso OSPF y luego le define el área 0

Nota: También puede realizar la configuración directamente en la subinterfaz, esta es una alternativa al comando tradicional visto arriba. Para usarlo tienes que eliminar el comando anterior network; no network network-id area area-id y agregar en la subinterfaz el siguiente comando; ip ospf process-id area area-id.

Para ver la configuración puedes usar el comando show ip ospf interface [interface].

Verificación del Funcionamiento de OSPF

Como hemos visto, los routeres OSPF utilizan un proceso de tres pasos para agregar eventualmente rutas aprendidas por OSPF a la tabla de enrutamiento IP. Primero, crean relaciones con los vecinos. Luego, construyen e inundan de LSA entre esos vecinos para que cada router en la misma área tenga una copia del mismo LSDB. Finalmente, cada router calcula independientemente sus propias rutas IP utilizando el algoritmo SPF y las agrega a su tabla de enrutamiento.

Nota: Si quieres puedes leer antes los conceptos básicos de OSPF y el Intercambio de información entre vecinos OSPF para comprender mejor la siguiente explicación.

El siguiente tema explica cómo mostrar los resultados de cada uno de esos pasos, lo que le permite confirmar si OSPF ha funcionado correctamente o no.

Los comandos show ip ospf neighbor, show ip ospf database y show ip route muestran información que coincide con cada uno de estos tres pasos, respectivamente.

Es habitual comenzar la verificación de OSPF observando el resultado del comando show ip ospf neighbor donde se muestra la relación de vecino del router con cada uno con los routeres vecinos.

Distintos comandos para la verificación en orden:

Config

Comandos:

show running-config
show ip protocols

Comandos network e ip ospf

Interfaces Habilitadas

Comandos:

show ip ospf interface
show ip ospf interface type number
show ip ospf interface brief

Descubrimiento con paquetes Hello

Vecinos

Comandos:

show ip ospf neighbor
show ip ospf neighbor type number

Inundación de LSAs

LSDB

Comando:

show ip ospf database

Cálculo de SPF

RIB

Comando:

show ip ospf rib

Distancia Administrativa

Rutas

Comandos:

show ip route
show ip route ospf
show ip route subnet mask
show ip route | section subnet

Ejemplo de vecino OSPF en un router:

R1# show ip ospf neighbor
Neighbor ID 	Pri 	State 		Dead Time 	Address 	Interface
2.2.2.2 	1 	FULL/DR 	00:00:37 	10.1.12.2 	GigabitEthernet0/0/0
3.3.3.3 	1 	FULL/DR 	00:00:37 	10.1.13.3 	GigabitEthernet0/1/0
4.4.4.4 	1 	FULL/BDR 	00:00:34 	10.1.14.4 	GigabitEthernet0/2/0

Detalles de la Tabla de Vecindad

Interface: Esta es la interfaz del router local conectado al vecino. Por ejemplo, el primer vecino en la lista es alcanzable a través de la interfaz G0/0/0 de R1.

Address: Esta es la IP del vecino en ese enlace.

State: Exiten muchos estados (que ya hemos visto en capítulos anteriores), FULL seria lo correcto y seria un estado completamente funcional para este caso.

Neighbor ID: Éste es el ID del router vecino.

En los enlaces que se usa un router designado ó en inglés Designated Router (DR), en el estado también se lista el rol del router vecino después de / (DR, BDR, o DROTHER. Como resultado, el estado normal de funcionamiento debería ser:

Detalles de los Estados

FULL/ –: El estado del vecino es completo (full), con el «-» en lugar de letras significa que el enlace no usa un DR/BDR.

FULL/DR: El estado del vecino es full, y el vecino es un DR.

FULL/BDR: El estado del vecino es full, y el vecino es el backup DR (BDR).

FULL/DROTHER: El estado del vecino es full, y el vecino no es un DR o BDR. (Esto también implica que el router local is un DR o BDR porque el estado es FULL.)

2WAY/DROTHER: El estado del vecino es 2-way, y el vecino no es un DR o BDR—esto es, un router DROther. (Esto también implica que el router local es también un router DROther porque de otra manera el estado debería ser FULL.)

Ejemplo de Rutas IPv4 Agregadas por OSPF

R4# show ip route
Codes: 	L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
	D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
	N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
	E1 - OSPF external type 1, E2 - OSPF external type 2
! Additional legend lines omitted for brevity

Gateway of last resort is not set

      10.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O 	10.1.1.0/24 [110/2] via 10.1.14.1, 00:27:24, GigabitEthernet0/0/0
O 	10.1.2.0/24 [110/2] via 10.1.14.1, 00:27:24, GigabitEthernet0/0/0
C 	10.1.4.0/24 is directly connected, Vlan4
L 	10.1.4.4/32 is directly connected, Vlan4
O 	10.1.12.0/24 [110/2] via 10.1.14.1, 00:27:24, GigabitEthernet0/0/0
O 	10.1.13.0/24 [110/2] via 10.1.14.1, 00:25:15, GigabitEthernet0/0/0
C 	10.1.14.0/24 is directly connected, GigabitEthernet0/0/0
L 	10.1.14.4/32 is directly connected, GigabitEthernet0/0/0
O 	10.1.23.0/24 [110/3] via 10.1.14.1, 00:27:24, GigabitEthernet0/0/0

En la salida del comando show ip route del ejemplo anterior puedes ver marcadas las rutas que fueron agregadas por OSPF, estas se identifican por la «O«.

También puedes ver que la distancia administrativa es 110 [110/2]. El 2 [110/2] hace referencia a la métrica de OSPF para esta ruta.

También se lista la interfaz de salida (G0/0/0) para llegar al next-hop que es la dirección IP 10.1.1.4.1.

RID: Configurar el ID del Router OSPF

Para elegir el RID, un router Cisco utiliza el siguiente proceso. Ten en cuenta que el router deja de buscar una ID para el router una vez que uno de los pasos identifica un valor a usar.

  1. Si el comando router-id rid es configurado, este valor es usado como RID.
  2. Si cualquier interfaz de loopback tiene una dirección IP configurada, y la interfaz esta levantada (up), el router elige el número de la dirección IP más alta entre esas interfaces de loopback.
  3. El router elige el número de dirección IP más alta de todas las interfaces que estan up

Configurar OSPF Multiarea

Entendiendo cómo configurar OSPF con una única área ya sólo necesitas entender un concepto más para configurar OSPF Multiárea por lo que seré breve.

Tomemos como ejemplo la siguiente imagen que tiene tres áreas.

Multiáreas en OSPF
Ejemplo de Multiáreas en OSPF

Para configurar las distintas áreas podemos ingresar los siguientes comandos en la CLI:

router ospf 1
 network 10.1.1.1 0.0.0.0 area 0
 network 10.1.2.1 0.0.0.0 area 0
 network 10.1.12.1 0.0.0.0 area 23
 network 10.1.13.1 0.0.0.0 area 23
 network 10.1.14.1 0.0.0.0 area 4

Configuraciones Adicionales de OSPFv2

Existen algunas configuraciones muy populares en OSPFv2 que son opcionales, estas funcionalidades que se pueden configurar son:

  • Interfaces pasivas
  • Rutas por defecto
  • Métricas
  • Balance de carga

Configurar Interfaces Pasivas en OSPF

A veces, un router no necesita formar una relación de vecindad con vecinos en una interfaz. A menudo, no existen otros routeres en un enlace en particular, por lo que el router no tiene la necesidad de seguir enviando mensajes repetitivos de Hello OSPF. En estos casos puedes convertir la interfaz en pasiva, lo que significa que

  • OSPF continua anunciando acerca de las subredes que están conectadas a la interfaz.
  • OSPF no no envía paquetes Hellos OSPF en esa interfaz.
  • OSPF no continua procesando cualquier mensajes Hello en esta interfaz.

Comando: passive-interface type number

Ejemplo:

! Primero, haz cada subinterfaz pasiva directamente
router ospf 1
 passive-interface GigabitEthernet0/0.1
 passive-interface GigabitEthernet0/0.2

! O, cambia el estado por defecto a pasivo, y haz que las otras interfaces no sena pasivas
router ospf 1
 passive-interface default
 no passive-interface GigabitEthernet0/0/0
 no passive-interface GigabitEthernet0/1/0
 no passive-interface GigabitEthernet0/2/0
R1# show ip ospf interface g0/0.1
GigabitEthernet0/0.1 is up, line protocol is up
  Internet Address 10.1.1.1/24, Area 0, Attached via Network Statement
  Process ID 1, Router ID 1.1.1.1, Network Type BROADCAST, Cost: 1
  Topology-MTID	Cost 	Disabled 	Shutdown 	Topology Name
	0 	 1 	   no 		   no 		  Base
  Transmit Delay is 1 sec, State DR, Priority 1
  Designated Router (ID) 1.1.1.1, Interface address 10.1.1.1
  No backup designated router on this network
  Timer intervals configured, Hello 10, Dead 40, Wait 40, Retransmit 5
    oob-resync timeout 40
    No Hellos (Passive interface)
! Lines omitted for brevity

Configurar Rutas por Defecto (Gateway) en OSPF

En el Capítulo 16.3, “Enrutamiento Estático”, vimos algunos de los usos y beneficios de las rutas por defecto, con ejemplos de rutas por defecto estáticas. Exactamente por esas mismas razones, las redes pueden usar OSPF para anunciar rutas por defecto.

El caso más clásico de utilizar un protocolo de enrutamiento para anunciar una ruta por defecto tiene que ver con la conexión de una empresa a Internet.

La siguiente imagen muestra la idea de cómo OSPF anuncia la ruta por defecto, con una configuración OSPF específica. En este caso, una empresa se conecta a un ISP (Internet Service Provider) con su Router R1. Ese router tiene una ruta estática predeterminada (destino 0.0.0.0, máscara 0.0.0.0) con una dirección de next-hop del router del ISP. Luego, el uso del comando OSPF default-information originate (Paso 2) hace que el router anuncie una ruta por defecto usando OSPF a los routeres remotos (B1 y B2).

Cómo Configurar Ruta por Defecto (Gateway) en OSPF
Cómo Configurar Ruta por Defecto (Gateway) en OSPF
! The next command is from Router R1. Note the static code for the default route
R1# show ip route static
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
! Rest of the legend omitted for brevity

Gateway of last resort is 192.0.2.1 to network 0.0.0.0

S*     0.0.0.0/0 [254/0] via 192.0.2.1
! The next command is from router B01; notice the External route code for the default
B1# show ip route ospf
Codes: 	L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
	D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
	N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
	E1 - OSPF external type 1, E2 - OSPF external type 2
! Rest of the legend omitted for brevity

Gateway of last resort is 10.1.12.1 to network 0.0.0.0

O*E2 	0.0.0.0/0 [110/1] via 10.1.12.1, 00:20:51, GigabitEthernet0/1/0
	10.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
O 	  10.1.3.0/24 [110/3] via 10.1.12.1, 00:20:51, GigabitEthernet0/1/0
O 	  10.1.13.0/24 [110/2] via 10.1.12.1, 00:20:51, GigabitEthernet0/1/0

Configurar Métricas en OSPF

Los routeres Cisco permiten tres maneras diferentes de cambiar el costo en la interfaz OSPF:

  • Uando el subcomando ip ospf cost x parados en la configuración de la interfaz.
  • Usando el cálculo por defecto para la interfaz, y cambiando la configuración de ancho de banda de la interfaz, lo que hara cambiar el cálculo para el valor del costo.
  • Usando el cálculo por defecto para la interfaz, y cambiando la configuración del ancho de banda de referencia en OSPF (que es 100 Mbps), lo que hara cambia el valor calculado.

La siguiente lista resume las reglas sobre cómo un router establece sus costos de interfaz OSPF:

  1. Configura el costo explicitamente usando el comando ip ospf cost x con un valor entre 1 y 65,535 inclusive.
  2. Aunque debe evitarse, cambia el ancho de banda de la interfaz con el comando bandwidth speed,siendo la velocidad un número en kilobits por segundo (Kbps).
  3. Cambia la referencia del ancho de banda, usando el comando auto-cost reference-bandwidth ref-bw, con una unidad de megabits por segundo (Mbps).

Configurar Balanceo de Carga en OSPF

Cuando un router usa SPF para calcular la métrica de cada una de varias rutas para llegar a una subred, una ruta puede tener la métrica más baja, por lo que OSPF coloca esa ruta en la tabla de enrutamiento.

Sin embargo, cuando las métricas se vinculan para múltiples rutas a la misma subred, el router puede colocar múltiples rutas de igual costo en la tabla de enrutamiento (el valor predeterminado es cuatro rutas diferentes) dependiendo de la configuración del comando maximum-paths number.

Por ejemplo, si una red tiene seis rutas posibles para lguna parte de la red y deseas que se usen todas las rutas, los routeres pueden configurarse con el subcomando maximum-paths 6 dentro de router ospf.

De esta manera, al tener varias rutas con el mismo costo, el router puede balancear el tráfico para ese mismo destino, es decir, el router podría enviar un paquete por la primera ruta, el siguiente paquete por la segunda ruta, el siguiente paquete por la tercera ruta, y luego comience de nuevo con la primera ruta para el siguiente paquete.

Nota, la configuración por defecto del valor para maximum-paths varia entre distintos routeres.

Deja un comentario